Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

#1 2019-05-31 14:55:55

ahangarha
New member
Registered: 2019-05-31
Posts: 3

[SOLVED] Cannot install FluxBB 1.5.11 with sqlite

Hi

There are few things I wanted to commit to the project to make it more friendly with RTL languages. For this purpose I needed to have a test machine to check my changes, so I tried to install FlexBB on my local machine. But it doesn't work.

As I open the site, it goes to install page but it shows me this error:

An error was encountered
Error: This PHP environment does not have support for any of the databases that FluxBB supports. PHP needs to have support for either MySQL, PostgreSQL or SQLite in order for FluxBB to be installed..

I made some tweeks in functions.php file and introduced few function which helped me see install page. It was working that much I could get error (in case of missing required fields) but If everything was right, I was getting a blank page.

I have tried to find some solution but nothing worked for me.

I am using PHP 7.2 and want to use sqlite (of course version 3). I am running Ubuntu 19.04. and I got FluxBB through cloning it from github repo.

What should I do?

Last edited by ahangarha (2019-06-21 18:57:05)

Offline

#2 2019-05-31 15:22:45

Visman
Member
From: Siberia
Registered: 2010-07-10
Posts: 1,381
Website

Re: [SOLVED] Cannot install FluxBB 1.5.11 with sqlite

Offline

#3 2019-05-31 15:39:06

ahangarha
New member
Registered: 2019-05-31
Posts: 3

Re: [SOLVED] Cannot install FluxBB 1.5.11 with sqlite

But I need it as same as the original repo. Otherwise I cannot be sure I am making right commits to the project

Offline

#4 2019-05-31 18:42:58

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,719
Website

Re: [SOLVED] Cannot install FluxBB 1.5.11 with sqlite

v1.6 will support SQLite v3.


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#5 2019-05-31 20:06:33

ahangarha
New member
Registered: 2019-05-31
Posts: 3

Re: [SOLVED] Cannot install FluxBB 1.5.11 with sqlite

Ok! then I should forget about Sqlite3.

I installed php-mysql and it seems the issue is resolved!

Last edited by ahangarha (2019-05-31 20:08:19)

Offline

Board footer

Powered by FluxBB