Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

#1 2019-02-06 02:01:49

A1Retouching
New member
Registered: 2019-02-06
Posts: 1

selecting install.php from fluxbb-1.5.11.zip fails and gives error

Hi,

this is the VERY FIRST time i post in this forum and the VERY FIRST time i attempt to install such a "thing" as this forum...

i created a database
hosting company is hostmonster
in the phpMyAdmin i selected "Import"
there i chose  the file "install.php" from the .zip file fluxbb-1.5.11.zip

the error message i'm getting is:

"
Error
Static analysis:

6 errors were found during analysis.

Unexpected character. (near "?" at position 1)
Unexpected beginning of statement. (near "?" at position 1)
Unexpected beginning of statement. (near "php" at position 2)
Unexpected beginning of statement. (near "The" at position 194)
Unexpected beginning of statement. (near "FluxBB" at position 198)
Unrecognized statement type. (near "version" at position 205)
SQL query:

<?php /** * Copyright (C) 2008-2012 FluxBB * based on code by Rickard Andersson copyright (C) 2002-2008 PunBB * License: ... GPL version 2 or higher */ // The FluxBB version this script installs define('FORUM_VERSION', '1.5.11')

MySQL said: Documentation

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?php

/**
* Copyright (C) 2008-2012 FluxBB
* based on code by Rickard Anderss' at line 1
"


any idea what i'm doing wrong?
thank you!

for "Character set of the file:" i chose "utf-8"
then the box is selected for "Allow the interruption of an import in case the script detects it is close to the PHP timeout limit. (This might be a good way to import large files, however it can break transactions.)"
and also the box is selected for "Enable foreign key checks"
Other options:
Enable foreign key checks (checkbox checked)
Format-specific options: SQL compatibility mode: [NONE]
and checkbox selected for "Do not use AUTO_INCREMENT for zero values"

that's all the information i have at this point

thank you in advance for your help!
Martin

Offline

#2 2019-02-06 22:51:39

Gianluigi
Member
Registered: 2018-06-23
Posts: 17

Re: selecting install.php from fluxbb-1.5.11.zip fails and gives error

You should not import that file direcly in the database.

Put all files from fluxbb zip to the hosting root using ftp or any file manager like this.
Than run the setup using your browser, load the page: http://www.yourwebsite.com/install.php

Fill the form, here you will insert your database name, user and password.

Offline

Board footer

Powered by FluxBB