Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

#1 2019-01-21 12:01:33

sebfromfrance
New member
Registered: 2019-01-21
Posts: 4

moving from the past (1.2...) to the latest version ?

Hi to all

I'm running since 2008 two websites... one with punbb 1.2.14 and the other one with fluxbb1.2.20.

As you may guess, I'm having more and more trouble with my websites (and the latest one is "PHP Deprecated:  preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead")

I think it's time to update but my problem is simple: I'm dumb

10 years ago, I choose punbb/fluxbb because it was said at this time that it was easy to install and use (and my 10 years experience is telling me this is right).

but is an update from 1.2 to 1.5.11 something easy to do by a dumb person...
I just want to be sure that nothing (posts, user etc...) will be lost because of this update...

best regards

Seb

Offline

#2 2019-01-21 15:45:27

Visman
Member
From: Siberia
Registered: 2010-07-10
Posts: 1,209
Website

Re: moving from the past (1.2...) to the latest version ?

Make full backups of the forum directory and database wink

Offline

#3 2019-01-22 07:36:11

sebfromfrance
New member
Registered: 2019-01-21
Posts: 4

Re: moving from the past (1.2...) to the latest version ?

I guess it will help ;-)

Offline

#4 2019-01-22 07:59:41

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,639
Website

Re: moving from the past (1.2...) to the latest version ?

The updater *should* work even with that old version, but as Visman said, backups are recommended.


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#5 2019-01-22 11:47:08

sebfromfrance
New member
Registered: 2019-01-21
Posts: 4

Re: moving from the past (1.2...) to the latest version ?

hum....

I went to the upgrade page, selected my version and obtain this message:

The branch you selected is out of date and is no longer support. We recommend you update to the latest branch (1.5) instead.

Offline

#6 2019-01-22 19:12:56

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,639
Website

Re: moving from the past (1.2...) to the latest version ?

That just means there are no patch files. You can still download the full 1.5.11 package from the homepage and use that to update your database. You will have to reapply modifications, though.


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#7 2019-01-23 08:02:57

sebfromfrance
New member
Registered: 2019-01-21
Posts: 4

Re: moving from the past (1.2...) to the latest version ?

ok

thanks to all ;-)

Offline

Board footer

Powered by FluxBB