Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

#1 2019-11-24 00:53:00

thepostaldude
Member
Registered: 2019-11-24
Posts: 4

Bad HTTP_REFERER when trying to set BaseURL

Hello, and greetings.

I am still kinda new to webhosting/ftp in general, and I am finally glad to find fluxBB, its more lightweight then PHPBB, and doesn't have 3000-something files.

However, i am having an issue, i am trying to set my base url to my sites domain, instead of (nameofmysite.domain/fluxbb-1.5.11/index.php), that isn't the name of the site, just using it as a place holder, but when i try to, i get this message.

"Bad HTTP_REFERER. If you have moved these forums from one location to another or switched domains, you need to update the Base URL manually in the database (look for o_base_url in the config table) and then clear the cache by deleting all .php files in the /cache directory."

I am looking through the root folder and everything in Filezilla, and i can't find this "o_base_url" at all, what am i doing wrong?

Offline

#2 2019-11-24 15:05:05

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,719
Website

Re: Bad HTTP_REFERER when trying to set BaseURL

You will have to change the value in the database, not the filesystem - do you have access to PhpMyAdmin or something similar?


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#3 2019-11-24 18:55:54

thepostaldude
Member
Registered: 2019-11-24
Posts: 4

Re: Bad HTTP_REFERER when trying to set BaseURL

Franz wrote:

You will have to change the value in the database, not the filesystem - do you have access to PhpMyAdmin or something similar?

I manged to fix it through a reinstall, but thanks for the response, but I am currently in another issue.

I can preview a post, and post just fine, but they spit out these two errors on top.

Deprecated: Function create_function() is deprecated in /home/vhosts/gsreborn.6te.net/forum/include/parser.php on line 98

Deprecated: Function create_function() is deprecated in /home/vhosts/gsreborn.6te.net/forum/include/functions.php on line 2066

Like i said, both work, but these errors pop up on time. Is there anyway to hide them or fix them? I tried changing error_reporting to error_reporting(E_ALL ^ E_DEPRECATED);, like a lot of people said to, and it doesn't fix it, what do i do?

Offline

#4 2019-11-24 19:26:29

thepostaldude
Member
Registered: 2019-11-24
Posts: 4

Re: Bad HTTP_REFERER when trying to set BaseURL

I also am having issues installing a plugin, i get this error.
Warning: require(./forum/plugins/common.php): failed to open stream: No such file or directory in /home/vhosts/SITENAME/forum/plugins/install_mod.php on line 80

Fatal error: require(): Failed opening required './forum/plugins/common.php' (include_path='.:/opt/remi/php73/root/usr/share/pear:/opt/remi/php73/root/usr/share/php:/usr/share/pear:/usr/share/php') in /home/vhosts/SITENAME/forum/plugins/install_mod.php on line 80

I don't get it, common.php is there! Please help...I can't find any other support anywhere else for this

Offline

#5 2019-11-25 02:10:16

Visman
Member
From: Siberia
Registered: 2010-07-10
Posts: 1,381
Website

Re: Bad HTTP_REFERER when trying to set BaseURL

Like i said, both work, but these errors pop up on time. Is there anyway to hide them or fix them? I tried changing error_reporting to error_reporting(E_ALL ^ E_DEPRECATED);, like a lot of people said to, and it doesn't fix it, what do i do?

Use the latest changes from dev-master https://github.com/fluxbb/fluxbb/archive/master.zip

I don't get it, common.php is there! Please help...I can't find any other support anywhere else for this

Which plugin are you trying to install?

Offline

#6 2019-11-25 20:59:57

thepostaldude
Member
Registered: 2019-11-24
Posts: 4

Re: Bad HTTP_REFERER when trying to set BaseURL

Visman wrote:

Like i said, both work, but these errors pop up on time. Is there anyway to hide them or fix them? I tried changing error_reporting to error_reporting(E_ALL ^ E_DEPRECATED);, like a lot of people said to, and it doesn't fix it, what do i do?

Use the latest changes from dev-master https://github.com/fluxbb/fluxbb/archive/master.zip

I don't get it, common.php is there! Please help...I can't find any other support anywhere else for this

Which plugin are you trying to install?

dakuju, the github version words without any errors.

I am trying to install this plugin, because i want to make use of bbcode.

https://fluxbb.org/resources/mods/custom-bbcode/

Offline

#7 2019-11-26 03:27:02

Visman
Member
From: Siberia
Registered: 2010-07-10
Posts: 1,381
Website

Re: Bad HTTP_REFERER when trying to set BaseURL

Read the readme.txt file from the modification archive and follow all the steps in order.

Offline

Board footer

Powered by FluxBB