Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

#1 2011-06-14 06:11:40

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

[Adaptation for 1.5.x] Auto-Poll v1.2.2

Hello,

As I was working with daris on a script to convert my CB forum to FluxBB, I decided to update the Auto Poll Mod which I found the closest to CB's poll system among all FluxBB poll mods.

I so started from the copy that is present on daris's Trac page, then I made the following changes :
- Localized the admin part (new language file : admin_plugin_polls.php)
- Added a French translation
- Fixed a missing file name in the Affected files list in readme.txt
- Updated the line numbers to seek in readme.txt
- Changed the … HTML entities into their UTF-8 characters
- Updated the mod infos (mod version, fluxbb version) and added myself as contributor.

The MOD is now available in FluxBB.org's repository : View download page
It is also available on GitHub : https://github.com/MissGeek/FluxBB-Auto-Poll-MOD
Available languages : English and French
Mod version : 1.2.2
Works on : FluxBB 1.5.0 and above. If you still run FluxBB 1.4.x, take this older version
Tested OS : Ubuntu and Windows
Tested browser : Firefox and Chrome

I'm looking forward for any report.

Ishimaru

EDIT on 10/09/11 : Updated to v1.1.1
- Moved install_mod.php to files/install_mod.php for compatibility with Patcher Mod (reported by daris via GitHub)

EDIT on 19/06/11 : Updated to v1.2
- Many fixes done, in install_mod.php in order to work with 1.4/1.5's MDK
- Changed an instruction regarding moderate.php, for the code to find has changed in 1.5

EDIT 03/02/13 : Updated to v1.2.1
- Fixed newline format for all files. Now all files use UNIX newline format (LF)
- Added HTTP errors arguments for message() where 'No View', 'No permission' and 'Bad request' language keys are used. This change makes the mod being not compatible anymore with FluxBB 1.4.x.
- replaced 'four-space indentation' by tabulation, for a proper display according to user preferences when viewed with a text editor.
- Replaced old PunBB copyright notices with FluxBB's new one.

EDIT 2015/12/22 Updated to v1.2.2
- Placed back the revamped install_mod.php file that was gone thanks to my airhead... -_-
- Fixed a bad copy/paste in one of the code block to find and updated the line numbers to fit with FluxBB 1.5.9.
- Fixed a misspelled language key in both admin language files and the page that uses this key (labol -> label)
- Fixed a bad naming of one added field in the group table : it was created as "post_polls" instead of "g_post_polls" and this caused an error message while attempting to reach the plugin admin page.
IMPORTANT : If you already installed this MOD before downloading this version, you must use the "update_from_1.1.php" file on your forum root in order to fix everything that was added by the install_mod.php file in prior versions.

Last edited by Ishimaru Chiaki (2015-12-22 09:53:30)


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#2 2011-06-15 02:04:52

quy
Administrator
From: California
Registered: 2008-05-09
Posts: 926

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Please consider using the Fluxbb MDK found here. Review the template install_mod.php script for examples using the database API to create tables and add fields to existing tables.

Offline

#3 2011-06-15 07:06:10

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Actually, I'm waiting for daris to see this post before doing anything because I don't know if he'll want to add the update to his Trac page.


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#4 2011-06-15 14:33:49

daris
Developer
From: Poland
Registered: 2008-05-09
Posts: 557

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

I'm not an author of this mod, so you can update it and even add to fluxbb repository smile If you want to maintain this mod, i'll delete it from my svn tongue

Offline

#5 2011-06-15 23:15:58

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

OK, so I'll look for this next WE, for I leave this Friday to spend the weekend with my parents at our 5th wheel.


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#6 2011-06-17 13:21:13

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

drat… I meant by "next week", not by "next WE"…  By the way, as I'm currently having an uveitis in my right eye, I'll wait until it gets better before preparing the package.


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#7 2011-08-25 05:31:17

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Hello,

After six weeks of treatment against an uveitis, two weeks of vacation in my 5th wheel, and three weeks of computer issues, I'm finally back and ready for developing !

Now I've got just a question regarding the author listing.

In the package I took from daris's repository, the install_mod header was as follows :

// Some info about your mod.
$mod_title      = 'Auto Poll';
$mod_version    = '1.0';
$release_date   = '2009-09-07';
$author         = 'Koos - original version by Mediator';
$author_email   = 'pampoen10@yahoo.com';

Knowing that I'll be the new maintainer, how should I manage that multiple-authoring ?

Because in the readme, here's what I had put :

##      Mod version:  1.1.0

##   Works on PunBB:  1.4.*

##     Release date:  2009-09-07
##      Review date:  2011-06-14

##           Author:  Koos (pampoen10@yahoo.com)

##  Original Author:  Mediator (med_mediator@hotmail.com)

##     Contributors:  BN (http://la-bnbox.fr), Ishimaru Chiaki (http://ishimaru-design.servhome.org)

That's how it looks in the original copy that I grabbed from the repo :

##      Mod version:  1.0

##   Works on PunBB:  1.2.*

##     Release date:  2009-09-07

##           Author:  Koos (pampoen10@yahoo.com)

##  Original Author:  Mediator (med_mediator@hotmail.com)

##     Contributors:  BN (http://la-bnbox.fr)

Thanks in advance.

Ishimaru


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#8 2011-08-29 23:43:17

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Bump, for I'm still waiting for an answer...

Meanwhile, I'm learning Git.

[EDIT] Repo link : https://github.com/MissGeek/FluxBB-Auto-Poll-MOD

Last edited by Ishimaru Chiaki (2011-08-30 00:13:26)


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#9 2011-08-30 09:58:35

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,719
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Just do something like

Your name - based on work by Koos and Mediator

And the more complete version in the README.


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#10 2011-08-30 18:47:59

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Thanks Franz !  It's now updated on my repo !  If everything seems fine to you, I'll send the zipped package.


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#11 2011-08-31 14:05:47

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,719
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Just go for it smile


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#12 2011-08-31 23:50:11

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

It's now done !  On the same time, I checked in the hdiff to make sure I had no update to do.

But I didn't know that I didn't need to indicate the version in the poll title... and I can't remove it !
Link : http://fluxbb.org/resources/mods/auto-p … ses/1.1.0/


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#13 2011-09-06 02:13:24

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Bump !

Could someone fix my mistake please ?


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#14 2011-09-06 02:52:09

Franz
Lead developer
From: Germany
Registered: 2008-05-13
Posts: 6,719
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

You could have just edited the modification: http://fluxbb.org/resources/mods/auto-poll-v110/

I did it now.


fluxbb.de | develoPHP

"As code is more often read than written it's really important to write clean code."

Offline

#15 2011-09-06 21:25:41

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Franz wrote:

You could have just edited the modification: http://fluxbb.org/resources/mods/auto-poll-v110/

I did it now.

Darn... I didn't see it


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#16 2011-10-09 05:56:24

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Auto-Poll Mod updated to v1.1.1

daris reported me via Github that the install_mod.php must be located inside (and note beside) /files directory in order to make the Mod compatible with Patcher Mod.  The file has then been moved.

EDIT : Grrr! I misunderstood daris's message >.< I sent him a message (via github) about this mistake.

Last edited by Ishimaru Chiaki (2011-10-09 06:12:31)


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#17 2011-10-09 08:51:48

daris
Developer
From: Poland
Registered: 2008-05-09
Posts: 557

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

There is no matter where the file is located (so it could be in mod directory or inside files directory). You have to define correct file location in readme

Offline

#18 2011-10-09 20:25:45

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

But do I have to modify anything or not, after that commit ???
The answer needs to be clear, as I'm already in kernel panic !

Last edited by Ishimaru Chiaki (2011-10-09 20:26:17)


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#19 2011-10-22 21:43:07

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

still no clear answer… if this continues like this, I'll give up and ask YOU to update it if needed because I can't decipher blurry answers !!


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#20 2011-10-23 06:34:29

daris
Developer
From: Poland
Registered: 2008-05-09
Posts: 557

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Yes, this is fixed in 1.1.1

Offline

#21 2011-10-24 06:17:17

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Thanks… at last !

Now I can post about the update on fluxbb.fr !


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#22 2012-02-05 06:23:02

Ishimaru Chiaki
Member
From: Baie-Comeau, Quebec, Canada
Registered: 2011-05-14
Posts: 77
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Hello, I come to announce that I released a RC of the new 1.2 version !

After I saw an issue reported that is caused by an obsolete statement in a query, I discovered (really too late) that there were more differences between 1.2 and 1.4 than I expected while no one told me about this earlier, causing me to open this discussion where I express my frustration about not having all the needed info at the right time.

So with some advices from the French team, I updated the MOD so the new version now uses the 1.4 MDK.  On the same time, an update script has been written, in order to fix wrong table/field parameters on boards where a 1.1 version has been installed.

Here is the changelog :
- Revamped install_mod.php in order to conform it to FluxBB's 1.4 MDK template
- Updated the lines to search, to make them fit with 1.4.8
- Fixes wrong character set in polls table for those who installed the 1.1.x version of this MOD
- Fixes wrong engine usage for polls table in MySQL(i) databases using InnoDB engine
- Change column type from LONGTEXT to TEXT for polls table in MySQL(i) databases (pgsql and sqlite were already using this type
- Added some details in readme.txt

There is actually no codechange, for the three latest FluxBB releases have no codechange entering in conflict with the MOD and no bug other than database-related issues were reported.

Even if I tested an update on a testboard where a 1.1 version of this MOD was installed, and a clean install on a fresh FluxBB install in order to fix any bug, some bugs might be still hiding, so I decided to release a Release Candidate, in order to have this MOD tested before its release on FluxBB repository.

Volunteering for testing

If you know how to install a test FluxBB forum locally (with Wamp, etc.), then you can test.

Here are what have to be tested.

Test #1 : MOD update

You have to test an update.  For this, you must follow these instructions :
- install the 1.1 release available here
- Post several polls containing special characters (é, è, œ, ê, à, etc.) in the poll options.  To add a poll to a topic, you must check the "Add poll" options in the topic options when you post a new topic)
- Perform an update using the update_from_1.1.php available here.
- See if there is any bug

Note : If you already installed the 1.1 version of this MOD on your board, make a file and database backup, so you can work on a copy locally (on Wamp, etc.)

As much as possible, I want results from all supported database types (MySQL(i) w/o InnoDB, pgsql, sqlite)

Second test : MOD install

You have to test a clean install.  For this, you must follow these instructions :
- On a fresh FluxBB install, install the new version of the MOD available here
- See if there is any bug

As much as possible, I want results from all supported database types (MySQL(i) w/o InnoDB, pgsql, sqlite)

I'm looking forward for results, before I officialize the release !

Thanks in advance.

Ishimaru


Alienware PC running Win7 64bits - GIMP 2.8 - XHTML/CSS (advanced) - PHP/MySQL (medium)
FluxBB Migration Tool on GitHub
My art gallery

Offline

#23 2012-02-17 10:28:20

Elliene
Member
Registered: 2011-03-17
Posts: 58

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

In my testing guests cant vote. In admin panel i have select that guests also has permission.

Last edited by Elliene (2012-02-17 14:06:40)


"Never believe what you publish, and never publish what you believe"

Offline

#24 2012-05-07 12:21:26

Scimonster
New member
Registered: 2012-05-07
Posts: 2

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Hello. How can i change my vote, using this mod?

Offline

#25 2012-05-08 22:30:45

shiguy101
Member
Registered: 2012-03-29
Posts: 92
Website

Re: [Adaptation for 1.5.x] Auto-Poll v1.2.2

Scimonster wrote:

Hello. How can i change my vote, using this mod?

was this answered?

Offline

Board footer

Powered by FluxBB