Fork me on GitHub
Subscribe 0

Ticket #7 (fixed enhancement)

Only reindex / preparse if necessary when upgrading

  • Created: 2010-05-23 21:15:57
  • Reported by: Franz
  • Assigned to: Reines
  • Milestone: 1.4.0
  • Component: upgrading
  • Priority: normal

This should be done by adding new constants to indicate if its required or not.

History

Reines 2010-05-23 21:38:35

  • Owner set to Reines.

Reines 2010-05-26 10:13:15

I've done a patch for this, but don't currently have the time to test it - if anyone would like to give it a test that would be great...

http://pastebin.com/Mk2ycvDe

Cheers

Franz 2010-05-26 10:55:11

I will take a look.

Reines 2010-05-27 20:21:30

  • Status changed from open to fixed.

There were a couple bugs in that patch, I've now fixed them and commit though, I think it should be good now.

http://gitorious.org/fluxbb/fluxbb/comm … a4fc8c5874

quy 2010-05-28 02:37:13

  • Status changed from fixed to open.

Immediately after a fresh install, this message is displayed: "Your FluxBB database is out-of-date and must be upgraded in order to continue. Please run db_update.php in order to complete the upgrade process."

o_searchindex_revision and o_parser_revision should be added to the config table in install.php.

Reines 2010-05-28 07:52:35

Ah thank you, no idea why I forgot that...

Should be fixed in 0d57508,though I don't have time at the moment to test it.

Reines 2010-05-28 07:52:44

  • Status changed from open to fixed.

Franz 2010-05-28 07:54:14

That should be fine. I just wanted to commit it this way, too.