Fork me on GitHub
Subscribe 2

Ticket #269 (fixed bug)

Issue with the new search system

  • Created: 2011-01-31 21:12:12
  • Reported by: Fran├žois
  • Assigned to: Reines
  • Milestone: 1.4.4
  • Component: search
  • Priority: normal

I have an issue with the new search system. I always come to this board with a favorite : action=show_24h (show_recent now).

Before the change, when I log in, I go back to the "show_24h" page with the new posts markup.

But since you redirect the user with a search id, I have a "no hits" after the login redirection.

To reproduce :
- Go to the following page when you're log out : http://fluxbb.org/forums/search.php?action=show_recent
- You can see results
- Click on "Login" in the navlinks bar, and log in
- You're redirected on the "previous page", but with the following message : Your search returned no hits.

History

Reines 2011-01-31 21:24:00

  • Milestone set to 1.4.4.

I can revert that change if you want - the only reason I changed it was to be consistent since before some searches redirected to the search ID instantly, and some only when accessing page 2 and above.

Fran├žois 2011-01-31 23:01:45

I understand the consistent question wink. Can you do that the first search id will be used after the login ?

Reines 2011-01-31 23:50:26

  • Owner set to Reines.
  • Status changed from open to fixed.

I've changed it so that only "regular" (i.e. keyword/author) searches are redirected. Quick searches are only redirected when changing pages.