Fork me on GitHub
Subscribe 5

Ticket #1022 (fixed enhancement)

Require PHP 5.6

  • Created: 2015-02-25 12:00:02
  • Reported by: Visman
  • Assigned to: Franz
  • Milestone: 1.6
  • Component: code
  • Priority: normal

Stop support PHP4 in next relise.
And 5.0 - 5.5 too.

As part of this ticket, any fallback code written for older versions should be removed.

History

chris98 2015-02-26 08:04:08

A lot of hosts still use PHP 5.3 (including my own actually), I think it's a bad idea to drop PHP 5.3 support.

There is also the option (not that I see anyone wanting to) but on hosts such as my own, you can change the PHP version to 5.2, so I don't think it's as outdated as PHP 4 yet.

Comment edited 1 times (Diff)

Studio384 2015-03-03 18:26:57

Sure... Let's kill of support of 54% of all systems out there.

That doesn't sound like a verry bright idea. PHP 5.3 is currently the most used version of PHP, 5.2 is on third place. Not a good idea.

Comment edited 1 times (Diff)

Visman 2015-03-04 11:00:11

PHP 5.3 is already out of date, this version is not supported by the developers, this version contains a security error and so on.

Ordinary people are using PHP version below 5.4 have security problems not only for themselves but also for the entire Internet.

Studio384 2015-03-05 18:44:21

That's the theory. For the reality, dropping support for PHP 5.2 and 5.3 is just a realy bad idea. It doesn't matter if it contains security errors or not, if people are using that, they know these problems are there, not to mention that PHP 5.4, 5.5, 5.6 and the future 7.0 also contain security issues, if you like it or not. No doubt a lot of PHP 5.4+ users are also on an outdated version of their branch, that also have security issues. That's just a non-argument.

Franz 2015-03-05 23:55:45

The problem is that these old versions contain well-known security vulnerabilities that won't be fixed. That is an important argument in my eyes.

Gil 2015-03-06 07:47:41

Are you speaking about version 1.5.9? For 1.5.9, it is imho too early, 5.2 and 5.3 are really used (5.2 + 5.3 ~> 60%; you can find some statistics + evolution graphs here - in French, sorry, but the graphs are easily understandable: http://blog.pascal-martin.fr/post/stati … 4-10.html). For version 2.0, no problem of course (Laravel itself is >=5.4, 2.0 in stable version won't be released before several months or more, and anybody can still use 1.5 branch).

Comment edited 1 times (Diff)

Visman 2015-03-06 08:06:50

Very, very bad that people are using older versions of PHP. But this does not mean that they should be supported.

123 2015-03-08 18:14:35

Yes but in fluxbb 2 xd
Fluxbb 1.5x fix bug
Fluxbb 2 new function

Visman 2015-03-09 02:32:53

No, in 1.5.9 or 1.6.0
This is not a new functions, this fix vulnerabilities wink

Gil 2015-03-09 23:36:10

You cannot exclude about 60% of the users. In this case, you should indeed do another branch (1.6.0), reserved for PHP 5.4+, and / but continue to support in parallel the 1.5 branch.

Visman 2015-03-10 05:16:28

Expired medicines you are taking, too? smile

Gil 2015-03-10 21:23:42

Yes, some people are taking expired medicines because they don't have any other choice (not enough money, not enough knowledge...).

http://blog.pascal-martin.fr/post/php-v … 10-en.html

If you decide to offer fluxBB versions for PHP 5.4+ only, to remove all PHP 5.2/PHP 5.3 compatible version, you will de facto exclude a large percentage of possible users. I think it is a very bad idea. It is better to keep a PHP 5.2/5.3 version, even if you can explain that is should be better to use a newer version.


You said:

PHP 5.3 is already out of date, this version is not supported by the developers...

The problem is not developers, but users.

Ordinary people are using PHP version below 5.4 have security problems not only for themselves but also for the entire Internet.

It is a good idea to try to educate ordinary people... But you should try to provide a software for ordinary people, not for geeks smile

Comment edited 1 times (Diff)

Visman 2015-03-11 01:55:43

This statistic is only a consequence, not a cause that programmers from year to year to support old versions of PHP.
P.S. In analogy to IE6, whose support had to stop 10 years ago.

Comment edited 1 times (Diff)

chris98 2015-03-11 13:32:01

The only reason I'm using PHP 5.3 is because it's what my host has setup for the default version. I would much rather use PHP 5.5 - even though it is available however, you are changing the PHP version for your account only, therefore adding another request, or at least adding something different from what the default is. And it doesn't show error messages in the browser, or log them, just a 500 Internal server error due to changing it from the default, which becomes a pain to use.

Therefore, I'd rather use the default PHP version they have selected. I would be thrilled for them to change the version to 5.5, but I don't really see that happening. I imagine loads of other people are in the same boat.

Studio384 2015-12-27 21:41:52

  • Milestone set to 1.6.

Issue #1044 requires us to drop support for PHP 4.4 and 5.0 anyway, so this can be added to the 1.6 milestone. Anyway, my argument for PHP 5.3 from earlier this year, still stands. While we've now grown to no longer really need to support 5.2 (as it is below 10% now, I find that reasonable), 5.3 is still used by a lot of people. Security issues or not, there are people out there that are simply tied to that version and can't just upgrade that easy. As I doubt we're going to make any ground-breaking changes in FluxBB 1.6 that will require PHP 5.4-specific features, there really is no reason to not allow these people to update too.

Studio384 2015-12-27 22:18:52

  • Owner set to Studio384.

Franz 2018-07-18 09:28:32

  • Owner Studio384 removed.

Franz 2018-07-18 09:29:15

  • Description changed. (Diff)
  • Summary changed from Stop support PHP4 to Require PHP 5.6.

Franz 2018-07-18 09:45:24

  • Owner set to Franz.

Franz 2018-07-18 09:52:51

Commit d4bb5ad to fluxbb 1.6-next

Require at least PHP 5.6.4

Refs #1022.

Franz 2018-07-18 09:58:45

Commit c7ef697 to fluxbb 1.6-next

Remove some conditionals for older PHP versions

Refs #1022.

Franz 2018-07-19 22:12:21

Commit 453aed1 to fluxbb 1.6-next

Remove get_microtime() function

It's no longer needed in PHP 5.x.

Refs #1022.

Franz 2018-07-19 22:12:34

Commit fe016fd to fluxbb 1.6-next

Use predefined superglobal for calculating request time

Available since PHP 5.4.
See http://php.net/_server.

Refs #1022.

Franz 2018-07-21 21:35:00

Commit a33632a to fluxbb 1.6-next

Remove handling of register_globals

Deprecated since PHP 5.3.

Refs #1022.

Franz 2018-07-21 21:36:15

Commit 1e23480 to fluxbb 1.6-next

Remove handling of magic_quotes

Deprecated since PHP 5.3.

Refs #1022.

Franz 2018-07-21 21:48:01

Commit 457e28c to fluxbb 1.6-next

Remove function fallbacks for older PHP versions

Refs #1022.

Franz 2018-07-23 22:15:59

  • Status changed from open to fixed.