Forums

Unfortunately no one can be told what FluxBB is - you have to see it for yourself.

You are not logged in.

Announcement

FluxBB 1.5.6 and 1.4.12 released

These releases fix a security issue - please update your forums! Download links: v1.5.6 | v1.4.12

#1 2008-07-28 20:46:00

Pierrot
Member
Registered: 2008-07-28
Posts: 45

First time FluxBB user with some questions...

Hi all!

I'm sorry to post these all in one place...

I have 4 sites using Wordpress. I'd like to set up a forum/community on 3. After a few weeks of shopping around and trying a few out locally I have very happily decided to use FluxBB.

Here are my preliminary questions...

1. How seriously would you try to persuade me not to use 1.3 - beta 2 on a live site? I've tested it out locally and love the changes (especially to the CSS files!). I'd like to just start with it.

2. How would you suggest including my Wordpress header? In testing 1.2.20 I just added...

'<?php require_once("../wp-blog-header.php");?>
<?php get_header(); ?> '

... to the top of FluxBB's header.php and it worked. In 1.3 - beta 2 it broke the administrator page (got a blank page). When I tried adding it to all of the files individually I had the same problem.


Thanks very much!


Pierrot

Offline

#2 2008-07-28 20:53:55

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

1. Very seriously, since Beta 2 is very outdated and known to have issues. And it's a beta. I would either wait for a release candidate or stick with 1.2 and upgrade later.
2. You don't edit files in 1.3, that's the point of the extension system. If I were you though, I would look into using forum_include in the templates.

Offline

#3 2008-07-28 21:09:08

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Thanks Smartys,

I'll take your advice - I thought I'd try my luck though!

When you suggest waiting for a release candidate - I had a look at the roadmap, is there a new rough date set?

Since 1.2 and 1.3 are so different how difficult will the upgrade process be?

When you say use a forum_include do you mean include the forum into WP instead of the WP header into the forum?


Thanks again!

Offline

#4 2008-07-28 21:15:19

raptrex
Member
Registered: 2008-05-11
Posts: 121
Website

Re: First time FluxBB user with some questions...

try using this plugin to integrate wordpress
http://fluxbb.org/forums/topic/1320/flu … on-plugin/

Offline

#5 2008-07-28 21:31:58

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

Pierrot wrote:

When you suggest waiting for a release candidate - I had a look at the roadmap, is there a new rough date set?

There is no date set at this point.

Pierrot wrote:

Since 1.2 and 1.3 are so different how difficult will the upgrade process be?

Replace 1.2 files with 1.3 files, run a script, done.

Pierrot wrote:

When you say use a forum_include do you mean include the forum into WP instead of the WP header into the forum?

We don't have the documentation for 1.2 up on our site as far as I know, so I'll link to the PunBB docs:
http://punbb.informer.com/docs/faq.html#faq3_4

Offline

#6 2008-07-29 06:34:51

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Okay, I'm feeling pretty thick here.

I took out all of the header includes and tried Smartys' suggestion. I followed the documentation to the letter. All I really want to do is include my entire header (rotating logo, rotating ad and nav bar) as well as my footer. I'd rather not break it down and include each element.

If I add <pun_include "header.php"> to main.tpl and then copy my entire WP header.php file to include/user/  I get an error. Am I foolish to think that I can just include the entire WP file?

Also, I tried the plugin suggested above and got nowhere on my local machine. 

So now I have 2 questions...

1. Can I load my entire WP header.php file using the <pun_include "header.php"> method? If so, what am I doing wrong? If not, exactly what files should I include?

2. Is there any way I can get the

'<?php require_once("../wp-blog-header.php");?>
<?php get_header(); ?> '

... code to work if I can't get #1?

You know that feeling of frustration you get after hours of trying and failing at something? Oh well, I'll start again tomorrow!


Thanks,


Pierrot

Last edited by Pierrot (2008-07-29 06:35:36)

Offline

#7 2008-07-29 06:42:40

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

I'm sorry!

Here are two of the sites I'd like to add FluxBB to...

http://phauxshow.com/

http://sophistryandillusion.com/

Offline

#8 2008-07-29 07:57:51

yemgi
Member
From: Crawley, West Sussex
Registered: 2008-05-09
Posts: 78
Website

Re: First time FluxBB user with some questions...

<pun_include "header.php"> is for punBB1.2 if you try with FluxBB1.3 the syntax is <forum_include "header.php">

Offline

#9 2008-07-29 11:23:38

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

Create a file in include/user, call it header.php.

It should contain

'<?php require_once(FORUM_ROOT."../wp-blog-header.php");?>
<?php get_header(); ?> '

Offline

#10 2008-07-29 21:02:00

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

yemgi, thanks for the tip. I'm using v1.2.20. I had a look at your forum - great work!

Smartys, I still can't get it to work. Here's what I did (locally and live)...

1. Uploaded and installed new v1.2.20 package. Confirmed that it was working with no problems.

2. Created a file called header.php in this directory - phauxshow/forums/include/user/header.php - with exactly this code inside (without the back ticks ...

'<?php require_once(FORUM_ROOT."../wp-blog-header.php");?>
<?php get_header(); ?>'

3. Added <pun_include "header.php"> to the main.tpl file (in different places with in the file - but nothing worked)

in the end I got either a blank page or...

Fatal error: require_once() [function.require]: Failed opening required 'FORUM_ROOT../wp-blog-header.php'


What am I missing?!

Offline

#11 2008-07-29 21:05:14

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

Make sure the path to the file is actually correct.
And use PUN_ROOT instead of FORUM_ROOT, I have 1.3 on the brain wink

Moved to 1.2 support.

Offline

#12 2008-07-29 21:11:01

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Smartys,


Sorry, that's my fault! I posted in 1.3 because I was considering using that release - but then I ended up asking for 1.2 support in the same post.

I'll try again now!

Offline

#13 2008-07-29 21:16:01

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Okay, the header showed up when I used PUN_ROOT. I tried to log in and got...


Fatal error: Call to a member function set_prefix() on a non-object in /xxxx/xxxx/xxxxx/phauxshow/wp-settings.php on line 212

Offline

#14 2008-07-29 21:20:27

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

line 212 says $prefix = $wpdb->set_prefix($table_prefix);

I'm assuming that I don't need to have FluxBB on the same Database?

Offline

#15 2008-07-30 00:52:07

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Okay, now I have two problems...

1. As above, I can't move past the error I get. The header shows up but I get the error when I try to log in.

2. I got another installation on a different site working perfectly so I tried to go live with it. I got the following error even though I followed the same process as the first instal.

An error occured on line 55 in file /xxx/xxx/xxxx/xxxxx/forum/include/dblayer/mysqli.php.

FluxBB reported: Unable to connect to MySQL and select database. MySQL reported: Access denied for user 'xxxxxxxxx'@'localhost' (using password: YES)

Offline

#16 2008-07-30 01:04:39

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

1. It sounds like you can't just call wp-blog-header.php alone, but I'm no Wordpress expert. You should double check that with someone who is.

2. Your username/password for MySQL is incorrect or does not allow you to connect to the database you have chosen.

Offline

#17 2008-07-30 01:05:31

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Sorry, scratch # 2 - I accidentally included my db prefix with my password.

I installed the package and got exactly the same error message as the first instal. I'm wondering if it is an issue with WP 2.6 as it works with 2.5 locally. I would really like to avoid asking on their forum though as they aren't the friendliest!

Offline

#18 2008-07-30 01:19:15

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Smartys,


Thank you so much for all of your help, truly! I'll hammer away at this for a couple of days and post back when I get it working.

Offline

#19 2008-07-30 22:01:57

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

I'm trying to get 1.2 and 1.3 working locally on both Wordpress 2.5 and 2.6 in order to try to isolate the problem I'm having with the header include. Here is what I have.

All of my attempts follow the include method outlined above by Smartys...

1.2 works perfectly with WP 2.5 (unfortunately I'm only running it locally and not live).

1.2 works with WP 2.6 but breaks when I try to login to FluxBB. I get the error message posted above.

1.3 shows no change at all when I try to use the include method above (using forum).

I couldn't find any documentation on this but, Smartys, you said to not edit files in 1.3 - does that go for the include method as well? If not, how should I go about it?

2. You don't edit files in 1.3, that's the point of the extension system. If I were you though, I would look into using forum_include in the templates.

I know that some of these questions are WP relevant, but sincerely, the chances of me finding a solution on their forum and almost nonexistent. Does anyone have experience including their WP 2.6 header in either FluxBB 1.2 or 1.3?

Thanks!

Offline

#20 2008-07-30 22:08:50

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

Pierrot wrote:

1.2 works with WP 2.6 but breaks when I try to login to FluxBB. I get the error message posted above.

What error?

Pierrot wrote:

1.3 shows no change at all when I try to use the include method above (using forum).

I couldn't find any documentation on this but, Smartys, you said to not edit files in 1.3 - does that go for the include method as well? If not, how should I go about it?

You should be editing main.tpl and using
<!-- forum_include "whatever.php" -->
(where whatever.php is the actual file in include/user).

Offline

#21 2008-07-30 22:14:19

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

When I try to log in I get this error...

Fatal error: Call to a member function set_prefix() on a non-object in /xxxx/xxxx/xxxxx/phauxshow/wp-settings.php on line 212

wp-settings.php line 212 says...

$prefix = $wpdb->set_prefix($table_prefix);


Does...

You should be editing main.tpl and using
<!-- forum_include "whatever.php" -->
(where whatever.php is the actual file in include/user).

...work for 1.3 also? Because I can get it working for 1.2 (with the error above) but not 1.3.

Offline

#22 2008-07-30 22:17:16

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Smartys, thanks! I was using <forum_include "whatever.php"> instead of <!-- forum_include "whatever.php" -->

Offline

#23 2008-07-30 22:33:32

Pierrot
Member
Registered: 2008-07-28
Posts: 45

Re: First time FluxBB user with some questions...

Okay, after comparing 1.2 and 1.3 I can say this...

I got the header to show using their individual include methods. I changed only main.tpl in each case.

a) I can't log into either. I try, get a blank screen or error, hit page back and I'm logged in.
b) I can't make any changes - anytime I push any button I get a blank screen locally and the error message above when live.

Offline

#24 2008-07-30 22:45:05

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

If your problem is that Wordpress error, then all I can say is that you must be doing something wrong with respect to including the header.

http://wordpress.org/support/topic/174783

It looks like this is a known issue.

Offline

#25 2008-07-30 22:50:51

Smartys
Former Developer
Registered: 2008-04-27
Posts: 3,139
Website

Re: First time FluxBB user with some questions...

Hmm, try adding includes for wp-config.php and wp-includes/wp-db.php before the include for the blog header.

Offline

Board footer

Powered by FluxBB 1.5.6